1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice
What Do You Need In The Xf2 Xengallery Version? Vote for your choices here: http://www.sonnb.com/threads/what-do-you-need-in-the-xf2-xengallery-version.1539/

Help Only Errors When Trying To Import From Xfmg

Discussion in 'XenGallery' started by FunInAsia, Apr 24, 2016.

  1. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    Unfortunately i have several problems installing and configuring Xen Gallery.

    I could install the addin without problems.

    Then when i tried to import content completely from XFMG (1.1.6a) i got only errors.

    I had a Waindigo Import tool installed, so to make sure that it's not caused by this tool, i uninstalled the addon. And i tried to uninstall the Xen Gallery too....with many errors and it wasn't really uninstalled.
    Then installed it again....said the Addon already exist....ok....so i made an update of the Addon...worked...just that it complaint that the tables in the DB aleady exist....ok....worked anyway.

    I just set up the main category and then started complete import again....but:

    upload_2016-4-24_10-23-51.png

    I really get mad. I love the design of Xen Gallery but if i cannot import the XFMG content it is useless to me.
    I am really happy now that i tried this on my testforum first and not in productive environment...

    Please help.

    Thx in advance
     
    Last edited: Apr 24, 2016
  2. sonnb

    sonnb Administrator Staff Member

    Hello,

    Sorry to hear you get issue while using the addon. Do you have the error when uninstalled the addon?

    Regarding the error you get while importing, it was because of new media uploading in XenMediaGallery. I have fixed it locally but do not publish yet. I will send you privately and you can have a try again.
     
  3. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    WOW....that was fast reply.... :);)

    Ok, i will try again a complete uninstall first and if i get the same errors, i'll screenshot them...

    Thx for your help !
     
  4. sonnb

    sonnb Administrator Staff Member

    You are welcome. Let me know if you need any help.
     
  5. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    i completely uninstalled Xen Gallery - worked. Then uploaded all files again then overwritten the .php you sent me.
    When i try to install the addon again i get always timeouts just after a couple of seconds. (Other Addons i can install without timeouts)

    upload_2016-4-24_11-37-17.png
    After that if i try again...it says the Addon ID already exists...

    The Addon is shown in the list then but it's not installed at all

    If i try to delete it then again after a couple of seconds:

    upload_2016-4-24_11-39-25.png
    After that if i try to delete it again it says:

    Error Addon not found.

    It seems that it just puts the Addon on and off the list.

    If i do not delete it and just try to update the addon it works at the second try by updating the addon.

    Strange
     
  6. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

  7. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    Unfortunately even with your new import.php

    upload_2016-4-24_13-50-40.png
     
  8. sonnb

    sonnb Administrator Staff Member

    You do not need to uninstall/install over again. The error is weird and it must be something to do with your web server configuration not with XenGallery. You should take a look here: http://modwsgi.readthedocs.org/en/develop/configuration-directives/WSGIDaemonProcess.html search for inactivity-timeout= maybe you are configuring a too small number which will be timeout when XenGallery installs camera data. This error is root cause the all of your install/uninstall issues above.

    Regarding the import issue, I have replied in the conversation.
     
    otto likes this.
  9. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    As i told you, this "timeout" comes IMMEDIATELY when i start to install the addon, so there is something wrong.
    Same Behave now with ANY addon. Did no changes on the Server. Same Server as the Live System, so it's the same WSGIDaemon with same settings and in the live system all works fine. Just let me try to restore the backup then we will see the result...
     
  10. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    Btw. here's the newest result with the new php

    upload_2016-4-25_7-9-26.png
     
  11. sonnb

    sonnb Administrator Staff Member

    Make sure you have removed the existing custom fields after the previous import. As I can see here, the field caption has been imported before (or has been created manually). Just remove it and refresh the import to continue.
     
  12. sonnb

    sonnb Administrator Staff Member

    If you feel it is hard to do all these stuffs, send me the admin information, I will assist on with it.
     
  13. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    Let me please first restore so we can start over clean as it was before the first try.
    It just takes some time to uplouad the backup of 14GB on the webserver as my external FTP repository has a very poor upload rate...

    Btw....as far i know we never customized anything on XFMG....what exactly do you mean ?
     
  14. sonnb

    sonnb Administrator Staff Member

    I am taking about Custom field not customize style. You will see Import custom fields in the Importer.
     
  15. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    I was not talking about styles at all. As far i know nobody customized XFMG....
    We only had to set up once Exifs manually, that's all...
     
  16. sonnb

    sonnb Administrator Staff Member

    Just give me admin login information when you are done. I will help you with all of these things. Do not worry ;)
     
  17. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    Well...in general i know very well what i'm doing. 20y in IT Business as an admin...that's a lot of experience. Well i worked on Windows but even a bit on Unix and Vax... Anyway, i am not a Linux Pro and appreciate your help a lot.

    I had -when i cloned and set up the testing environment- heavy problems with timeouts when i tried to integrate the big database from the backup. Therefor i already adjusted the timeout settings in php.ini and httpd.conf each to 600 seconds. That worked then for the db upload and integration.

    In the meantime i never had timeouts like that and i upgraded Xenforo also to 1.5.7 on my prod environment...without problems. Those timeouts i see only in the testing environment and can't understand why as it is an 1:1 clone. Both runinng with zend opcache, different table prefixes everything set up fine. Believe me, it started right when i tried to make the import...which doesn't mean it is caused by that. Could be also coincidence...

    Of course, if you want to spend your time and investigate the problem, i can give you an admin account to do so. Appreciate.

    I can even give you an admin to check the server itself (have my own dedicated).

    Restore went fine, System should be clean now. I just update the test env. to 1.5.7 and XFMG 1.1.6a too, so we have the same preconditions.

    Let me know what you think and want to do....

    Cheers
    FunInAsia aka Holger
     
  18. sonnb

    sonnb Administrator Staff Member

    Sorry if I made you think that way. Just want to mention that you can have my help to convert them since I am more family with XenGallery and XenForo.
     
  19. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    Nothing wrong...i appreciate your help a lot. :)
     
  20. FunInAsia

    FunInAsia DELETE MY ACCOUNT ! Authorized

    Hi sonnb....are you in holiday or why i get no more answer from you in our conversations since 2 days ???
    I have urgent problems, please show yourslf up alive...
     

Share This Page